Автор Тема: Блокирование запуска screensaver_а при просмотре видео.  (Прочитано 301 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Vlad

  • Гость
Познакомился с K-meleon_ом. Замечательная программа. Но столкнулся с проблемой запуска скринсейвера. Нарыл в инете прогу, разложил по директориям, но она не работает, хотя в Preferences-Macro Extension показалась (savercontrol). Не подскажите в чем тут дело? А может есть другое решение проблемы?

Оффлайн rodocop

  • Глобальный модератор
  • Сообщений: 852
    • Просмотр профиля
дело скорее всего в том, что AutoIt-скрипт, который и определяет функционал расширения (макрос только интегрирует его в интерфейс браузера), написан в 2009-м году - очевидно в расчете на структуру веток реестра ХР.

На более новых системах, возможно (не уверен) структура эта изменена - и потому не работает. Такое допущение. Если скрипт переписать (а исходник в комплекте идет) и перекомпилировать - то может и заработать.

Я правил некоторые скрипты AutoIt, но вообще не большой спец по этому вопросу.

Оффлайн Coronerr

  • Участник форума
  • Сообщений: 161
  • Пол: Мужской
  • [ ] Я не робот.
    • Просмотр профиля
На более новых системах, возможно (не уверен) структура эта изменена - и потому не работает.
На семёрке в реестре всё также, дополнение работает, параметр ScreenSaveActive переключает. За 8 и 10 — не скажу.

Vlad

  • Гость
как раз "семёрка" у меня и стоит...

Vlad

  • Гость
Благодарю Coronerr и rodocop. Всё заработало и скрипт рабочий. Просто в меню (Edit->Configuration->Saver Control) надо было выключить скринсейвер (Disable SSaver). При выходе из К-мелеона скринсейвер автоматически включится.